Hoe koppel je een Cisco netwerkomgeving aan een Brocade netwerkomgeving?

kennislevel 1 kennislevel 2 kennislevel 2 Technisch niveau Waddinxveen, 18 april 2017 Waddinxveen, 18 april 2017 Networking Networking

Hieronder wordt beschreven hoe het koppelen van een Cisco netwerkomgeving aan een Brocade netwerkomgeving in zijn werk gaat, op basis van een port-channel met LACP en de koppeling van twee verschillende management VLAN's.

Cisco switches maken gebruik van untagged management default vlan 1. Daaraan wordt in deze situatie een Brocade VDX infrastructuur gekoppeld, met als default management vlan 999.

Deze twee omgevingen worden gekoppeld middels een LAG (port-channel) met LACP.

In onderstaande configuratie wordt vanuit de Cisco omgeving alle untagged default-vlan verkeer geïnjecteerd in untagged vlan 999, binnen de Brocade omgeving.

Hoe ga je te werk?

Cisco Catalyst configuratie voor LAG, op basis van LACP en het taggen van alle vlan's met untagged default vlan 1: !
interface Port-channel1
description Uplink to VDX
switchport trunk encapsulation dot1q
switchport mode trunk
!
!
interface GigabitEthernet0/1
description Uplink to VDX
switchport trunk encapsulation dot1q
switchport mode trunk
channel-group 1 mode active
!
interface GigabitEthernet0/2
description Uplink to VDX
switchport trunk encapsulation dot1q
switchport mode trunk
channel-group 1 mode active
!
interface Vlan1
ip address 10.1.200.1 255.255.0.0
Brocade VDX configuratie voor LAG, op basis van LACP met alle vlan tagged en vlan 999 untagged: SW-VDX-2# sh run int ten 1/0/17
interface TenGigabitEthernet 1/0/17
channel-group 1 mode active type standard
no fabric isl enable
no fabric trunk enable
lacp timeout short
no shutdown
!
SW-VDX-2# sh run int ten 2/0/17
interface TenGigabitEthernet 2/0/17
channel-group 1 mode active type standard
no fabric isl enable
no fabric trunk enable
lacp timeout short
no shutdown

SW-VDX-2# sh run int port-channel 1
interface Port-channel 1
vlag ignore-split
speed 1000
description Uplink to Cisco 6509
switchport
switchport mode trunk
switchport trunk allowed vlan all
no switchport trunk tag native-vlan
switchport trunk native-vlan 999
spanning-tree shutdown
no shutdown

SW-VDX-2# show running-config rbridge-id 1 interface Ve 999
rbridge-id 1 interface Ve 999 ip proxy-arp
ip address 10.1.200.254/16
vrrp-extended-group 1 advertisement-interval 1
no enable
no preempt-mode
!
no shutdown
!
!
!

SW-VDX-2# sh run interf vlan
interface Vlan 1
!
interface Vlan 2
name Servers
!
interface Vlan 4
name XEN
!
interface Vlan 192
!
interface Vlan 999
name Management
!
Controleer de werking van het geheel op de Cisco Catalyst: Cisco6509#ping 10.1.200.254

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.1.200.254, timeout is 2 seconds:
.!!!!
Success rate is 80 percent (4/5), round-trip min/avg/max = 1/1/1 ms
Cisco6509#ping 10.1.200.254

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.1.200.254, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/1 ms
Cisco6509#
Controleer de werking op Brocade VDX: SW-VDX-2# ping 10.1.200.1
Type Control-c to abort
PING 10.1.200.1 (10.1.200.1): 56 data bytes
64 bytes from 10.1.200.1: icmp_seq=0 ttl=255 time=7.472 ms
64 bytes from 10.1.200.1: icmp_seq=1 ttl=255 time=1.153 ms
64 bytes from 10.1.200.1: icmp_seq=2 ttl=255 time=1.123 ms
64 bytes from 10.1.200.1: icmp_seq=3 ttl=255 time=1.051 ms
64 bytes from 10.1.200.1: icmp_seq=4 ttl=255 time=1.116 ms
--- 10.1.200.1 ping statistics ---
5 packets transmitted, 5 packets received, 0% packet loss
round-trip min/avg/max/stddev = 1.051/2.383/7.472/2.545 ms
SW-VDX-2#

Wilt u hulp van een gecertificeerd Brocade expert?

Contact

SolidBE B.V.
Maarten Schoutenstraat 19
2741 SV Waddinxveen

KVK 51248794
NL 82 3170 846 B01
NL07 RABO 0157 5353 98